
ROOT for beginners

First Day
Discovering the

graphical environment



Welcome to ROOT !
Today's menu:

We present a guided tour of
basic use of ROOT in order to
plot spectra and make pretty
pictures ! For further information, you

should consult the "User's
Guide" at http://root.cern.ch

Handling ROOT files
Plotting 1-D spectra
Handling canvases

Decorating a figure
Fitting a 1-D spectrum

Operations on 2-D spectra
Saving figures



Handling ROOT files



TBrowser – the ROOT navigator
• You just need to know one command in order to

start the ROOT file/spectra browser :
root [0] new TBrowser

Or you could do:
TBrowser toto
or
TBrowser *tata = new TBrowser

Explanations tomorrow (Day 2)!

http://caeinfo.in2p3.fr/root/Formation/en/Day1/hsimple.root



Open a ROOT file with
TBrowser

• In the File menu of TBrowser, select
"Open…"

• Select a file in the dialogue box which
appears:

1. Select the
file



Open a ROOT file with
TBrowser

2. Click
"Open"

• In the File menu of TBrowser, select
"Open…"

• Select a file in the dialogue box which
appears:



Looking at ROOT file contents

• The file has been added to the list of open ROOT
files - to see it, you have to display the list

1. Double click
on ROOT
Files



Looking at ROOT file contents

• Next click on the file to see its contents:

2. Click the file



Looking at ROOT file contents

• You see (if you choose the right options) a
list of spectra with their titles

3. Choose option
"detailed list"



Looking at ROOT file contents

• Icons represent the different types of spectra:
– profile, 1-D histogram, 2-D histogram, N-tuple…



Plotting spectra

First of all, 1-D spectra



Plotting a spectrum

• To plot a 1-D histogram, nothing could be
simpler: double-click it!

1. Double-click
histogram "hpx"



Discovering the canvas
(TCanvas)

• A new window appears - the canvas



The canvas objects
• This canvas contains many objects which

we can manipulate:

Spectrum
title

Statistics
box with
name of
histogram

Display
frame

"Y" axis

"X" axis

The histogram

Canvas



What is this object ?
• To see the identity of every object the

mouse passes over, activate the "Event
Status" bar in the "View" menu :

The bar appears below
the canvas:

Object title

Object
name

Mouse position
in pixel units
(0,0)=top left
corner

Position in
"spectrum"

units
+ bin contents

& partial integral
for spectra



What is this object ?
• Or, you can

"right-click" on
an object and
access its
context menu:

Right-click on
histogram
"hpx":

Object type (class)::
object name



The canvas objects (again)
• So we can identify the type (class) of every

object used in the canvas:

Spectrum
title
(TPaveText)

Statistics box
with name of
histogram
(TPaveStats)

Display
frame
(TFrame)

"Y" axis
(TAxis)

"X" axis (TAxis)

Histogram
(TH1F)

The canvas
(TCanvas)



Manipulating objects
• Use the mouse to move and resize objects…

With the left button
of the mouse you can
reposition and
redimension all
objects in the canvas



Activate the canvas editor
• To change colours, line widths, etc. we use

the canvas editor

Activate the
editor by selecting
"Editor" in the
"View" menu



Canvas editor
• The editor appears to the left of the canvas
• It displays/modifies the characteristics of the last

object selected with the mouse (careful!)
Name & type (class)
of last-clicked
object

E.g. Tick here to
make all spectra
scales on this canvas
logarithmic



Canvas editor

Like this !

• The editor appears to the left of the canvas
• It displays/modifies the characteristics of the last

object selected with the mouse (careful!)



Changing the look of a spectrum

1. Check you have
selected the right
object

• or "the art of clicking in the right place at the right time"…



Changing the look of a spectrum

2. Click the line-
colour box to
the palette

• or "the art of clicking in the right place at the right time"…



Changing the look of a spectrum

3. Choose a fill
style…

• or "the art of clicking in the right place at the right time"…



Changing the look of a spectrum

4. …and a colour in
order to activate it

• or "the art of clicking in the right place at the right time"…



Changing the look of a spectrum

5. And why not
change the title
while we're at it ?

• or "the art of clicking in the right place at the right time"…



Changing the look of a spectrum

…as well as the
range of displayed
axis values

On the second tab
you can change the
binning…

• or "the art of clicking in the right place at the right time"…



Handling the canvas*

*without smudging the artwork



Canvas manipulation
• If you want a new canvas:

Using an existing
one…

Using the browser…
WARNING !
Double-click on a
spectrum and it will be
drawn on the active
canvas, replacing any
previous content



Canvas manipulation
• To wipe the canvas clean:

Wipe only the active
(sub-)pad…

Wipe the WHOLE
canvas (careful!)



Manipulating the canvas
• To refresh the canvas display:

Sometimes, the result
of a modification is not
visible straight away.

To force an update of all
the objects on the canvas,
option "Refresh" can help*

*(and reduce stress levels
and anxiety…)



Manipulating the canvas
• Some useful options:

In the "Options" menu of
the canvas we also control
whether or not to show :

statistics boxes

histogram title

fit parameters



Manipulating the canvas
• Dividing the canvas to display several

spectra at once:

Open the context menu of
the canvas (right-click on
the canvas)

Select "Divide"



Manipulating the canvas

Number of columns

Number of rows

Margins between pads

Pad colour

Fill in the form,
e.g. to have 2x2 pads:

And click "OK"

• Dividing the canvas to display several
spectra at once:



Next, choose the pad
where you want to display
your spectrum
(click with middle button)

WARNING!
The first sub-pad is not
automatically selected

Manipulating the canvas
• Dividing the canvas to display several

spectra at once:



Exercise



Decorating a figure

Making pretty pictures



Adding objects to the canvas

• Open the toolbar

Select "Toolbar" in the
"View" menu



Adding objects to the canvas

• Open the toolbar

With the buttons we can
draw all sorts of
graphical objects on the
canvas…



Adding objects to the canvas

• Open the toolbar

…arc/circle, line,
arrow, diamond, ellipse,
rectangle, …



Adding object to the canvas

• Open the toolbar

…polyline, "curly line",
"curly arc", …



Adding objects to the canvas

• Open the toolbar

…marker, closed contour
(graphical cut selection
- Day 4!)



Add a pad to the canvas

• Spectra within spectra within…

Why add a pad ?

=> Easy way to have an
'insert' showing e.g. a
zoom

Pad = mini-canvas inside
a canvas (or a pad… etc.
etc.)



Adding a pad

• Spectra within spectra within…

Draw the pad, then
click on it with the
middle button to make
it active
(yellow border)*

*(true for all pads/
canvases)



Adding a pad

• Spectra within spectra within…

Then the next spectrum
we display will be drawn
in the active (yellow)
pad*

*(this is always true,
even with several
windows)



Adding text
• To make the figure self-explanatory, add a

legend…

Several choices are
available for adding
text, do you want just
text ('L' button)* or
text in a box ?

*(it's 'L' for 'LaTeX')



Adding text
• …using LaTeX (well, almost)

Example of a
'TPaveLabel'

Raw text entered:
-4#leq p_{x}#leq 4

To change font, size,
colour of text, use the
canvas editor



Exercise

Tip:
it's the 2-D
spectrum
'hpxpy' drawn
with option
"lego" (use the
'Options' drop-
down menu in
the browser)



Fitting a 1-D spectrum



Fits

• Simple fitting can easily be done using the
graphical interface

Draw spectrum
'hpx' and open its
context menu

Select "FitPanel"



Fits

Choose a function:

polN = Nth order polynomial

user = user-defined function
(Day 3)

• Simple fitting can easily be done using the
graphical interface



Fits

Change the range of the fit

• Simple fitting can easily be done using the
graphical interface



Fits

Click 'Fit' and the fit
will be performed, the
result appears in the
active pad/canvas
(unless you choose option
"N")

To see the fit
parameters :
menu "Options",
"Fit Parameters"

• Simple fitting can easily be done using the
graphical interface



Exercise



Working with 2-D spectra



Displaying 2-D spectra

• Several options are available for displaying
2-D histograms:

Divide a new canvas in 4.
In the browser,
double-click the spectrum
"hpxpy" of file
"hsimple.root"

By default, a "scatter-plot"
is drawn

Not very nice (but
sometimes useful)…



Displaying 2-D spectra

The "Option" drop-down menu of the
browser can be used to choose a
display option: "box", "lego", "colz" *

*Actually, there are
more of them -
"surf", "lego2",
"arrow"…

• Several options are available for displaying
2-D histograms:



An instructive little worked
example

• Let's use our 2x2 canvas & the browser to
display the 2-D histo "hpxpy" with 4
different plotting options:

Can you do it using what
you have learned so far ?



An instructive little worked
example

• Can't get the same spectrum to appear in 2
pads at the same time ?

Look at the spectrum list in
the browser.

Does something seem a
little strange ?

Why does 'hpxpy' appear
twice in the list ? *

(Maybe it's not the only one)
*You might need to
update the browser:
"View"->"Refresh"



An instructive little worked
example

Names ending in ";1" or ";N"
(N>=1) * are the objects in
the file (on disk)

They cannot be modified
(we opened the file in "Read
Only" mode).

*the 'N' is a version
or 'cycle' number

• Can't get the same spectrum to appear in 2
pads at the same time ?



An instructive little worked
example

Names without ";" are memory-
resident copies of the spectra:
these we can modify.

A new copy is made every time
you double-click a disk-resident
object.

The previous copy is destroyed !

• Can't get the same spectrum to appear in 2
pads at the same time ?



An instructive little worked
example

• Disk-resident vs. memory-resident objects

So to get the right result,
you have to make sure to always
click on 'hpxpy' (copy in
memory) and not 'hpxpy;1'
(disk-resident).

To remove the
statistics box, use
the 'Options' menu



An instructive little worked
example

• Tip: nice colours if you can get them…

With option 'col'/'colz', the
default colours are not very
attractive.

This will make a great
improvement:
root [0] gStyle->SetPalette(1)

Then update the canvas
(menu "Options"->"Refresh")
or click on the histogram.



Operations on 2-D spectra
• It's easy to generate projections or profile

histograms* from 2-D spectra

*i.e. plot the mean and
s.d. of one of the two
variables versus the other



Right-click to open the
context menu

Then select e.g. ProjectionX

• It's easy to generate projections or profile
histograms from 2-D spectra

Operations on 2-D spectra



You can give a name for
the new projection.

By default (if you leave
"_px") the name will be
"hpxpy_px".

• It's easy to generate projections or profile
histograms from 2-D spectra

Operations on 2-D spectra



You can limit the range
of bins included in the
projection.

By default, as here, all
bins are included.

• It's easy to generate projections or profile
histograms from 2-D spectra

Operations on 2-D spectra



Options:
"d" - plot in active canvas/pad
"e" - calculate errors
"[cut]" - use named graphical
cut to select bins (Day 4!)

• It's easy to generate projections or profile
histograms from 2-D spectra

Operations on 2-D spectra



By default, the projection
is not displayed, but should
be present in the browser
(after a "Refresh")

• It's easy to generate projections or profile
histograms from 2-D spectra

Operations on 2-D spectra



Exercise



Saving your figures

It'd be a pity to lose everything…



Saving a masterpiece
• Before saving, we'll remove the yellow border of the

active canvas - otherwise it'll be in the figure

In the canvas' context
menu select
SetBorderMode
change the value:
"0" = no border



Saving a masterpiece

• Open the menu "File", sub-menu "Save"

You can save an image of
your figure in many popular
formats (PS, PDF, GIF, JPG)
with the name c1.xxx by
default*

*With "Save As…" you can even choose the name you want



Saving a masterpiece

• What if I want to change the figure later ?

Two choices:
create some code ('c1.C')
or
save the objects ('c1.root')



Save the objects ???
• By choosing ".root" in menu "Save", a file

'c1.root' is created.
• In order to display the image later, you need to

open this file, e.g. with the browser:

It seems the file only contains
one object, c1.
But double-click it and…



Save the objects ???

…the figure is displayed.

In fact, a canvas is a sort of list of
objects to display on the screen.
The command "Draw" just adds an
object to this list…

• By choosing ".root" in menu "Save", a file
'c1.root' is created.

• In order to display the image later, you need to
open this file, e.g. with the browser:



Create some code ?
• By choosing "c1.C" in the menu, a file is

created which contains all the (C++)
instructions necessary to recreate our figure

You can look at
the result in any
text editor…



Create some code ?
• Tomorrow we will see how to use this kind

of code to create analysis scripts, etc.

Now this won't
hurt a bit…


